Πρόβλημα σε Spectrum 128k +2 grey (λύθηκε)

Άβαταρ μέλους
xaris_sm
Μέλος
Μέλος
Δημοσιεύσεις: 115
Εγγραφή: Πέμ Φεβ 14, 2013 10:59 am

Πρόβλημα σε Spectrum 128k +2 grey (λύθηκε)

Μη αναγνωσμένη δημοσίευσηαπό xaris_sm » Τρί Μαρ 12, 2013 3:17 pm

γεια σας παιδια,

προσπαθω να επισκευασω το πρωτο μου συστημα μιας και τον ειχαμε παρατησει στο παταρι στο πατρικο, θυμαμαι τον ειχαμε στειλει και στον ηλεκτρονικο της γειτονιας για επισκευη και εκανε τα "δικα του"

η αρχικη οθονη ειναι αυτη
σε όλλες τις εικόνες έχω μερικα πιξελς να αναβοσβηνουν...

http://aijaa.com/Z5LQTx

οποτε παω και βαζω...προσωρινα εστω

-νεο regulator Ιδιο
-ενα bc489 στην tr9 αντι για το ztx650 (αναποδα σε σχεση με το σχεδιο της πλακετας ebc/cbe εννοω)
-ενα bc213 στην tr8 αντι για ztx213 (το ιδιο σε σχεση με το σχεδιο της πλακετας)
-ενα bc557 στην tr7 αντι για 2n3904 (αναποδα σε σχεση με το σχεδιο της πλακετας ebc/cbe εννοω)

βγαζω όλλες τις μνημες, πηρα και 5 νεες spare,εβαλα βασεις και αρχισα να κανω δοκιμες μια μια τις μνημες οπως εκανε ο anemos με τον μονη διαφορα οτι η δικια μου οθονη στις δοκιμες με το ρεσετ ηταν αυτη

http://aijaa.com/rUySBB

οι καλες μνημες εβγαζαν αυτη την εικονα ενω οι καμμενες μονο λευκη εικονα χωρις γραμμες κιτρινες,

εχω φτιαξει και ενα scart καλωδιο,

οποτε βαζω όλλες τις καλες μνημες και περνω την παρακατω οθονη

http://aijaa.com/Vivecw

αλλαζω και cpu (εβγαλα απο τον 48κ) και παλι η ιδια οθονη

νομιζω οτι εχω φτασει κοντα βρε γ@μωτο...στο repair flow chart λεει να δοκιμασω επομενο την ROM, εσεις τι λετε γενικα με την περιπτωση μου? ειμαι βαριά? :D

σας ευχαριστω!
:scalo-line
Λύθηκε Τετ Απρ 17, 2013
----------------------------------------------------------------------------------------------------------------------------------
παντως απο την δικια μου περιπετεια εμαθα οτι τα πιο βασικα ειναι

-αλλαγη στο regulator 78S05 (και οπως λεει και ο Anemos καλυτερα να αλαχθει με το 78T05)
-αλλαγη στα τρανζιστορ τροφοδοσιας TR9 ZTX650 αντικατασταση με ZTX651, προσωρινη αντικασταση με BC489 που βρισκεται πιο ευκολα ( το 489 μπαινει αναποδα σε σχεση με το σχεδιο της πλακετας ), επισης αλαγη του ΤR8 ZTX213 με μονιμη αντικατασταση το BC213 που βρισκεται ευκολα, εδω θελει προσοχη πως θα μπει πανω στην πλακετα γιατι παιδευτικα, υπαρχουν 3 διαφορετικου τυπου ΒC213 οσον αφορα ebc,cbe ecb συνδιασμοι, το ZTX213 ειναι ebc οποτε εγω πηρα ενα BC213 οπου με τις δοκιμες κατεληξα οτι ηταν cbe οποτε και το εβαλα αναποδα σε σχεση με το σχεδιο της πλακετας

-δοκιμαζεις πρωτα τα ευκολα και τα ποιο βασικα να αλλαξεις οπως CPU/ROM/ULA/PCF φυσικα χρειαζεσαι ενα ιδιο συστημα να δουλευει οποτε και εγω αναγκαστικα και πηρα ενα απο ebay
πρεπει να ξερουμε οτι τα παραπανω λειτουργουν σιγουρα πριν παμε πιο κατω, καποιος βεββαια μπορει να θελει να αρχισει και απο τις μνημες πρωτα...

πριν αρχισουμε να ξηλωνουμε μνημες μπορουμε να φτιαξουμε αυτον τον προγραμματιστη eprom (κοστος περιπου 15 eyro μαζι με το αδειο epprom IC)

http://users.ntua.gr/dpiperid/MyWebPage ... ROMPro.htm (πολυ straight forward η διαδικασια)

να παρουμε μια αδεια eprom 27c256, να κατεβασουμε το RAM testet ROM απο εδω

http://www.fruitcake.plus.com/Sinclair/ ... Tester.htm (το bin file ειναι 8K, η αδεια eprom 32k εγω κατεβασα το bin το ανοιξα με εναν hex editor και το εκανα copy paste σε ολα τα 32k δηλαδη 4 φορες)

οποτε γραφουμε το νεο bin που ειναι 32k τωρα στην 27c256, βγαζουμε την ROM του +2 και βαζουμε το 27c256 την θεση του ROM του +2 (ειναι ιδια τα pinout)

αυτο τρεχει και σου βγαζει εαν υπαρχει προβλημα με τις μνημες, και τυχον επαφες χαλασμενες (data line) αλλα και περιοχη στις μνημες (address line) σε καθε τσιπ που δεν μπορει να διαβασει η και να γραψει data, οποτε δεν ξηλωνεις ολες τις μνημες αλλα μονο τις χαλασμενες

πολυ προσοχη οταν ξεκολησουμε μνημες και βαλουμε βασεις να γινει η δουλεια πολυ προσεχτικα και αργα να μην μεινουν λεκεδες απο κολησεις στις γραμμες της πλακετας και γινει βραχυκυκλωμα

κατι αλλό, η βασικες μνημες για το +2 grey ειναι τα ic25-32, εαν εδω ειμαστε καλα η εαν θελουμε να δουμε σε ποια περιοχη των μνημων 17-24 η 25-32 εχουμε προβλημα μπορουμε να ξεκηνισουμε τον +2 σε 16k mode, πως? βγαζουμε την rom στραβωνουμε το pin 27 να μην μπει στην βαση οταν το ξαναβαλουμε και το εννωνουμε προσωρινα με ενα καλωδιακι με το pin 28 της rom, εαν ξεκινησει εχουμε τα ic25-32 σιγουρα οκ
post 8 το ειδα απο εδω αυτο http://www.worldofspectrum.org/forums/s ... ctrum+128k


Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Τρί Μαρ 12, 2013 6:01 pm

Eχω να προτείνω τα εξής απλά αλλά σημαντικά πραματάκια για αρχή..
ΝΑ αλλάξεις πάλι το 78S05 (η με το καλύτερο 78T05 που αντέχει 3Α), γιατι μπορεί να τα τίναξε κατά τις δόκιμες..
Επειδη πιστεύω οτι κάποια μνήμη δε κουμπώνει σωστά..η καποιο ποδι δεν κανει 100% καλη επαφη..(εσύ μπορεί να τις βλέπεις κουμπωμένες, είναι ομως ?)
Να ελέγξεις εαν οι βάσεις ειναι καλά κολλημένες ,μηπως εχει χαλαρώσει κάποιο πιν απο κατω,η απο πάνω με τη θερμοκρασία κατά την συγκόλληση, και δεν κανει σωστή επαφή,η μνημη.
Να καθαρίσεις πολύ καλά με οινόπνευμα και πινέλο τα πινς από τις βάσεις των μνημών, και του CPU, γιατί μπορεί αν εχει μείνει υλικό συγκόλλησης σολντερινη,η λάδι που ειναι μονωτικά.., και κάποιο πινς να μη κάνει επαφή ενώ κουμπώνει.
Στη περίπτωση που δεις ίχνος λαδιού , γράσου, (σολντερινη η flux), πρέπει να καθαρίσεις και τις μνήμες γιατί θα έχει μείνει πάνω στα πόδια των ram.
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
xaris_sm
Μέλος
Μέλος
Δημοσιεύσεις: 115
Εγγραφή: Πέμ Φεβ 14, 2013 10:59 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό xaris_sm » Τρί Μαρ 12, 2013 6:07 pm

το καθαρισμα θα το κανω...λογικο ειναι αυτο που λες

το 78s05 εαν βγαζει τα +5 και +9 στα ποδαρακια του δεν ειναι οκ? εχω πολυμετρο

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Τρί Μαρ 12, 2013 6:13 pm

xaris_sm έγραψε:το καθαρισμα θα το κανω...λογικο ειναι αυτο που λες

το 78s05 εαν βγαζει τα +5 και +9 στα ποδαρακια του δεν ειναι οκ? εχω πολυμετρο

Οχι απαραίτητα.. ειχα τύχει σε ενα τέτοιο, να βγάζει σωστά τα ρεύματα, αλλα δεν ειχε ισχύ σε Α, ας πουμε αντι να αντέχει σε 1.5Α, δεν άντεχε ουτε σε 0.5,
αυτο οφείλεται σε καταπόνηση, η απλα με τις δοκιμές σε ενα απότομο ζόρι, και κάτι καίει εσωτερικά, έτσι υπολειτουργεί..
Το 78T05 (το οποιο ανακάλυψα πρώτος οτι κάνει για τον ΖΧ και μην ακούτε κατι ξένους που το παίζουν guru,και φιλαράκια.. yes-yes ) επειδή είναι , αντέχει και σε μια στραβή.. (απότομη ζήτηση ισχύς)
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
xaris_sm
Μέλος
Μέλος
Δημοσιεύσεις: 115
Εγγραφή: Πέμ Φεβ 14, 2013 10:59 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό xaris_sm » Τρί Μαρ 12, 2013 6:26 pm

Anemos έγραψε:
xaris_sm έγραψε:το καθαρισμα θα το κανω...λογικο ειναι αυτο που λες

το 78s05 εαν βγαζει τα +5 και +9 στα ποδαρακια του δεν ειναι οκ? εχω πολυμετρο

Οχι απαραίτητα.. ειχα τύχει σε ενα τέτοιο, να βγάζει σωστά τα ρεύματα, αλλα δεν ειχε ισχύ σε Α, ας πουμε αντι να αντέχει σε 1.5Α, δεν άντεχε ουτε σε 0.5,
αυτο οφείλεται σε καταπόνηση, η απλα με τις δοκιμές σε ενα απότομο ζόρι, και κάτι καίει εσωτερικά, έτσι υπολειτουργεί..
Το 78T05 (το οποιο ανακάλυψα πρώτος οτι κάνει για τον ΖΧ και μην ακούτε κατι ξένους που το παίζουν guru,και φιλαράκια.. yes-yes ) επειδή είναι , αντέχει και σε μια στραβή.. (απότομη ζήτηση ισχύς)



οκ να αγορασω ενα, για το τρ7 εχω μια αμφιβολια που εχει το bc557 να το αλλαξω και αυτο ε?

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Τρί Μαρ 12, 2013 6:45 pm

Απο την τελευταια εικονα που βγαζει.. 99% ειναι μνημη, μη πειραξεις κατι,μεχρι να κανεις αυτα που ειπα.
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
xaris_sm
Μέλος
Μέλος
Δημοσιεύσεις: 115
Εγγραφή: Πέμ Φεβ 14, 2013 10:59 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό xaris_sm » Τρί Μαρ 12, 2013 6:54 pm

Anemos έγραψε:Απο την τελευταια εικονα που βγαζει.. 99% ειναι μνημη, μη πειραξεις κατι,μεχρι να κανεις αυτα που ειπα.



:!!

Άβαταρ μέλους
xaris_sm
Μέλος
Μέλος
Δημοσιεύσεις: 115
Εγγραφή: Πέμ Φεβ 14, 2013 10:59 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό xaris_sm » Τετ Μαρ 13, 2013 9:43 pm

δυστιχως ακριβως την ιδια οθονη μου βγαζει,

ελαξα το 78s05 με νεο

εβγαλα τις μνημες και μετρησα τις γραμμες απο τις βασεις που καταληγει μια μια για να δω εαν οι κολησεις ειναι οκ, ειδα το σχεδιο απο εδω
http://tcg.speccy.cz/zoom/pics/plus2sch.png

σκουπισα την πλακετα με οδοβουρτσα και οινοπνευμα λευκο προσεχτικα....

το περιεργο ειναι οτι βγαζει ακριβως την ιδια οθονη απο εδω

http://hardware.speccy.org/reparar-i.html

:provlimatismenos

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Τετ Μαρ 13, 2013 9:57 pm

Δε βρήκες 78T05? , τεσπα.. κάτι πρέπει να παίζει με την τροφοδοσία πιστεύω..
Η εικόνα που σου βγάζει είναι απο μνήμες, η CPU.το ίδιο είχα και γω..
Τι τροφοδοτικό έχεις και πόσα αμπερ? επίσης μέτρησε τα 5 volt εν λειτουργία (συνδεμένος ο +2 , καθώς και τα 9ν να δεις αν μειώνονται εν λειτουργία, π.χ να πεφτει στα 8ν.
Αν έχεις άλλο PCU ,έστω 10ν ,και 12ν στην ανάγκη θα δουλέψει για τεστ..
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
xaris_sm
Μέλος
Μέλος
Δημοσιεύσεις: 115
Εγγραφή: Πέμ Φεβ 14, 2013 10:59 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό xaris_sm » Τετ Μαρ 13, 2013 10:18 pm

το δοκιμαζω με το κανονικο του τροφοδοτικο 2.1amber

και εχω και ενα μαυρο siclair τροφοδοτικο νομιζω ειναι απο 48κ αλλα αυτο ειναι 1.4amber να το βαλω?

τα +5 και +9 πως να τα μετρησω εαν τα βγαζει ο regulator η να ψαχων τασεις στο κυκλωμα τροφοδοσιας? παντως τα tr8/9 εχουν ρευματα γενικα

μηπως εχω βαλει αναποδα το τρ8?

δεν ξερω εαν πρεπει να δω κατι αλλο πιο ειδικο? γιατι δεν ειμαι και ηλεκτρονικος...

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Τετ Μαρ 13, 2013 11:25 pm

Φιλε, το regulator βγαζει μονο 5, δηλαδη περνει 9 και βγαζει 5, τα 9 έρχονται απο το τροφοδοτικο.. αυτο παει..
Θα μετρήσεις εν λειτουργία, τα 9 που έρχονται, και τα 5, με το πολυμετρο στα ποδια του regulator, προσοχη μη τα βραχυκυκλώσεις..
Το TR8 θα το δουμε μετα.. θελω να βρεις τα datasheet και των δυο.
υγ. ουτε εγω ειμαι επαγγελματίας ηλεκτρονικός, απλα εμαθα στη πορεία μερικα πράματα..
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
xaris_sm
Μέλος
Μέλος
Δημοσιεύσεις: 115
Εγγραφή: Πέμ Φεβ 14, 2013 10:59 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό xaris_sm » Τετ Μαρ 13, 2013 11:31 pm

Anemos έγραψε:Φιλε, το regulator βγαζει μονο 5, δηλαδη περνει 9 και βγαζει 5, τα 9 έρχονται απο το τροφοδοτικο.. αυτο παει..
Θα μετρήσεις εν λειτουργία, τα 9 που έρχονται, και τα 5, με το πολυμετρο στα ποδια του regulator, προσοχη μη τα βραχυκυκλώσεις..
Το TR8 θα το δουμε μετα.. θελω να βρεις τα datasheet και των δυο.
υγ. ουτε εγω ειμαι επαγγελματίας ηλεκτρονικός, απλα εμαθα στη πορεία μερικα πράματα..



με ποιο τροφοδοτικο να τις κανω τις δοκιμες? του γκρι η του 48?

επισης βρηκα ενα που βγαζει 14-15 βολτ με πολλα αμπερ, να το βαλω η θα κανω ζημια?

Άβαταρ μέλους
xaris_sm
Μέλος
Μέλος
Δημοσιεύσεις: 115
Εγγραφή: Πέμ Φεβ 14, 2013 10:59 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό xaris_sm » Τετ Μαρ 13, 2013 11:41 pm

xaris_sm έγραψε:
Anemos έγραψε:Φιλε, το regulator βγαζει μονο 5, δηλαδη περνει 9 και βγαζει 5, τα 9 έρχονται απο το τροφοδοτικο.. αυτο παει..
Θα μετρήσεις εν λειτουργία, τα 9 που έρχονται, και τα 5, με το πολυμετρο στα ποδια του regulator, προσοχη μη τα βραχυκυκλώσεις..
Το TR8 θα το δουμε μετα.. θελω να βρεις τα datasheet και των δυο.
υγ. ουτε εγω ειμαι επαγγελματίας ηλεκτρονικός, απλα εμαθα στη πορεία μερικα πράματα..



με ποιο τροφοδοτικο να τις κανω τις δοκιμες? του γκρι η του 48?

επισης βρηκα ενα που βγαζει 14-15 βολτ με πολλα αμπερ, να το βαλω η θα κανω ζημια?



εκανα τις δοκιμες με το γκρι τροφοδοτικο
εκτος πλακετας βγαζει βγαζει 12
στην πλακετα on βγαζει 10
το regulator βγαζει 4

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Πέμ Μαρ 14, 2013 12:48 am

To regulator standard πρέπει να βγάζει 5V.
Επισης..
Oταν λες εβαλες καλες μνημες, εβαλες καινουριες? η κατα τον ελεγχο νομιζεις ειναι οκ?
Μια αν δεν ειναι οκ, θα σου βγαζει αυτην την οθονη.. αλλαξε τις θεσεις τους μηπως δουλεψει!, καποια μπορει να στην "κανει"..
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
xaris_sm
Μέλος
Μέλος
Δημοσιεύσεις: 115
Εγγραφή: Πέμ Φεβ 14, 2013 10:59 am

Re: Προβλημα σε Spectrum 128k +2 grey

Μη αναγνωσμένη δημοσίευσηαπό xaris_sm » Πέμ Μαρ 14, 2013 9:46 am

Anemos έγραψε:To regulator standard πρέπει να βγάζει 5V.
Επισης..
Oταν λες εβαλες καλες μνημες, εβαλες καινουριες? η κατα τον ελεγχο νομιζεις ειναι οκ?
Μια αν δεν ειναι οκ, θα σου βγαζει αυτην την οθονη.. αλλαξε τις θεσεις τους μηπως δουλεψει!, καποια μπορει να στην "κανει"..



1) Οποτε πρεπει να βρω ενα τροφοδοτικο 12v να συνδεσω για να βγαζει το regulator σιγουρα 5.

τις μνημες τις καλες απο τις χαλασμενες τις δοκιμασα με τον τροπο που γραφεις, μια μια στην θεση ic32 χωρις να υπαρχουν αλλες μνημες στο board,
οποτε εκανα ρεσετ και δοκιμαζα, απλα στις δοκιμες δεν μου εβγαζε ακριβως την οθονη οπως στην δικια σου περιπτωση αλλα την παρακατω που μοιαζουν

http://aijaa.com/rUySBB

παντως οι χαλασμενες μνημες δεν εβγαζαν καθολου κιτρινες γραμμες οποτε και αυτες αντικατεστισα...

2) επισης θα κανω παλι ελεγχο τις μνημες μια μια με καλο τροφοδοτικο

3) θα μετρησω παλι τις γραμμες απο τις μνημες αφου βαλω τις μνημες πανω για να ακουμπαω τα ποδαρακια των μνημων και οχι των βασεων οπως εκανα πριν...

και ειδα και τις γραμμες απο το κυκλωμα τροφοδοσιας, τρ8/τρ9 και γυρο εξαρτηματα και ειναι οκ δεν υπαρχει καποια επαφη που δεν παιζει...

και βλεπουμε


Επιστροφή σε “ZX Spectrum / ZX-81 / QL”



Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: 1 και 0 επισκέπτες