ZX Spectrum +2 πρόβλημα (λύθηκε!)

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

ZX Spectrum +2 πρόβλημα (λύθηκε!)

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Τετ Σεπ 01, 2010 8:59 pm

Λοιπόν ξεκινώ νέο θέμα εδώ, για τον +2 μου τον "γκρι" που έχει πρόβλημα screen video.
Μετά από λίγο ψάξιμο ανακαλύψαμε μαζί με τον Jim,ότι ο πρώτος αίτιος είναι το transistor regulator 78S05
Πριν την αλλαγή του έδειχνε κάπως έτσι..

Εικόνα

Αφού αλλάχτηκε με καινούριο, η εικόνα δείχνει αυτό:

Εικόνα

που παραπέμπει τώρα σε καμένες μνήμες..,
οι μνήμες είναι οι 4164B-15 με 16 pin, και ελπίζω στην σύντομη αλλαγή τους ,αφού μπουν πρώτα βάσεις 16pin socket ,για την εναλλαγή των τεστ..

---------Η συνέχεια.. ----------------
Μετα το voltage regulator που αλλάχτηκε με ένα παρόμοιο στα 1.5A σειρά είχε ο έλεγχος των μνημών.
Όμως πρώτα έπρεπε να αποκολληθούν και οι 16 μνήμες ΧΩΡΙΣ να τραυματιστούν για να μπορούν να χρησιμοποιηθούν ξανά,όσες ήταν λειτουργικές!
Ομολογώ ότι για να πετύχω την καλύτερη δυνατή αποκόλληση για να μη τραυματίσω την μητρική πλακέτα και τις μνήμες,χρειάστηκε πολύ υπομονή και πατέντες! όχι μια.. αλλά πολλές..
Αφού λοιπόν αποκολλήθηκαν όλες οι μνήμες μπήκαν βάσεις 16pin για να μπορούν να εναλλάσσονται εύκολα!

Εικόνα
Εικόνα

Αφού κολλήθηκαν οι βάσεις,οι οποίες χρειάστηκαν όλες τρόχισμα για να στενέψουν,γιατί οι μνήμες του +2 είναι πολύ κοντά η μια στην άλλη!..άρχισα τον έλεγχο μνημών! και πως?
Εδώ έχω ένα καινούριο δεδομένο να ενημερώσω τους τεχνικούς!
Στην κάτω σειρά μνημών και στην πρώτη από δεξιά θέση, (IC32) δοκιμάστηκε μια -μια μνήμη και γίνονταν έλεγχος της εικόνας αφού πατούσα και μια-δυο φορές το RESET!
Οι μνήμες που ήταν εντάξει έβγαζαν μια συγκεκριμένη εικόνα που μετά το reset φαινόταν 4 κάθετες χοντρές μπάρες χρώματος κίτρινο εναλλάξ με γκρι! (τεστ μια μνήμη κάθε φορά στη συγκεκριμένη θέση)
-- Κάπως έτσι.. --
Εικόνα

Βρέθηκαν λοιπόν 3 μνήμες καμένες - ελαττωματικές..
Τώρα.. μη έχοντας άλλες μνήμες για αντικατάσταση και γνωρίζοντας ότι είναι πανάκριβες (περίπου τα 8 ευρώ η κάθε μια!) θέλησα να πειραματιστώ με άλλου τύπου μνήμες που βρήκα σε ένα παροπλισμένο PCW 512 Amstrad.
Αυτό βέβαια είχε άλλου τύπου και συγκεκριμένα μια οκτάδα M5M4257P-15 και μια οκτάδα από ΤΜ41256P-15 από 256k όλες, αντί τα 64Κ του Spectrum!
Εδω σας έχω και την έκπληξη! κάνοντας μερικούς συνδυασμούς βρήκα έναν συνδυασμό που δούλεψαν, αφήνοντας μου (για ρεζέρβα) και μια παραπανίσια μνήμη του ZX!
Ο συνδυασμός αυτός είναι ως εξής..
Όλη η κάτω σειρά γεμισμένη με τις κανονικές μνήμες του ZX,και η πάνω σειρά (μια παρά μια) αρχίζοντας με μνήμη του ZX,και καταλήγοντας σε μνήμη του Amstrad PCW.
Επέλεξα τον τύπο ΤΜ41256P-15 για την εναλλαγή γιατί ήταν και ο πιο σταθερός,το μηχάνημα δούλεψε για 30 λεπτά χωρίς κανένα πρόβλημα!

Ο δε CPU Zilog που είχε δούλευε τελικά μια χαρά.. αλλά αλλάχτηκε με τη CPU Z80-A που έβγαλα από τον Amstrad PCW!
Οι λόγοι που τον άλλαξα ήταν περισσότερο για πειραματισμό, αλλά.. είδα μια μικρή διαφορά στην ταχύτητα boot- reset του αρχικού screen! δε ξέρω..
ίσως ο συγκεκριμένος CPU να διαχειρίζεται καλύτερα τις γρήγορες μνήμες που ανακάτεψα.. ?

Εικόνα

FINAL screen!!

Εικόνα

Το χέρι του εξωγήινου? ?

Εικόνα

Τεστ με Divide..

Εικόνα

Δοκιμές σε games!

Εικόνα

Πρόσθεση πολύ μικρού ηχείου εσωτερικά του +2 (ο ήχος είναι χαμηλός,αλλά ενδεικτικά χρήσιμος μιας και ακούς τι γίνεται..)

Εικόνα
------------------------------------------------------------------------------
13-9-2010
Ήρθε το regulator : KA78T05 12>5v στα 3 Αμπέρ, και αλλάχτηκε το 1,5Ααρι 78S05 ..
------------------------------------------------------------------------------
Περιμένω τις μνήμες..
Συνεχίζετε! ..
Ήρθαν οι μνήμες όλα καλά.
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
ZX_Jim +
Z80 power CPU
Z80 power CPU
Δημοσιεύσεις: 1407
Εγγραφή: Παρ Σεπ 04, 2009 1:06 am
Επικοινωνία:

Re: ZX Spectrum +2 πρόβλημα απεικόνισης

Μη αναγνωσμένη δημοσίευσηαπό ZX_Jim + » Τετ Σεπ 01, 2010 9:49 pm

Δεν χρειάζονται όλα αντικατάσταση, μόνο τα προβληματικά.... (Αν εντοπιστούν! :) )
Γράφεις όμως 4165.... Μήπως είναι 4164? :?:
http://zxjim.blogspot.gr/

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: ZX Spectrum +2 πρόβλημα απεικόνισης

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Τετ Σεπ 01, 2010 10:24 pm

Ναι, 4164 είναι.. ;)
δεν είναι όλα καμένα,το θέμα είναι πότε θα τελειώσω τις βάσεις για τεστ, καθώς να βρω και 2-3 καινούρια..
άλλο ένα.. απαιτείτε μεγάλη προσοχή στην αποκόλληση,για να μπορούν να επαναχρησιμοποιηθούν..
για να δούμε πόσα θα την γλυτώσουν..:cry:
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
ZX_Jim +
Z80 power CPU
Z80 power CPU
Δημοσιεύσεις: 1407
Εγγραφή: Παρ Σεπ 04, 2009 1:06 am
Επικοινωνία:

Re: ZX Spectrum +2 πρόβλημα απεικόνισης

Μη αναγνωσμένη δημοσίευσηαπό ZX_Jim + » Πέμ Σεπ 02, 2010 12:34 am

Με 15Watt όλα... Το έχω κάνει εγώ που είμαι και ψιλοάσχετος.... :lol:
Προσοχή θέλουν οι γραμμές που έχει από το επάνω μέρος της πλακέτας... Ξεκολλάνε μαζί με τα ποδαράκια.... :(
http://zxjim.blogspot.gr/

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: ZX Spectrum +2 πρόβλημα απεικόνισης

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Πέμ Σεπ 02, 2010 11:44 pm

Παιδιά! δε το πιστεύω.. τον έφτιαξα !! :!! :D
συντομα περισσοτερα και φωτος! γιατι το θεμα εχει πολυ ενδιαφερον ! ! :shock:
EDIT:Jim! θέλω οπωσδήποτε ενα πρόγραμμα memory test για 128 ZX ;)
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
ZX_Jim +
Z80 power CPU
Z80 power CPU
Δημοσιεύσεις: 1407
Εγγραφή: Παρ Σεπ 04, 2009 1:06 am
Επικοινωνία:

Re: ZX Spectrum +2 πρόβλημα (λύθηκε!)

Μη αναγνωσμένη δημοσίευσηαπό ZX_Jim + » Παρ Σεπ 03, 2010 12:16 am

Δεν χρειάζεται, δεν είναι 48Κ... :lol:
Απλά βάλε ένα μεγάλο παιχνίδι, αν τρέξει είναι ΟΚ :!!
http://zxjim.blogspot.gr/

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: ZX Spectrum +2 πρόβλημα (λύθηκε!)

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Παρ Σεπ 03, 2010 12:26 am

οταν θα γραψω. θα καταλάβεις γιατι στο ζήτησα! :lol: :lol:
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
ZX_Jim +
Z80 power CPU
Z80 power CPU
Δημοσιεύσεις: 1407
Εγγραφή: Παρ Σεπ 04, 2009 1:06 am
Επικοινωνία:

Re: ZX Spectrum +2 πρόβλημα (λύθηκε!)

Μη αναγνωσμένη δημοσίευσηαπό ZX_Jim + » Παρ Σεπ 03, 2010 12:37 am

Απ' ότι ξέρω, κάνει ένα τεστ στην εκκίνηση, αν εντοπίσει πρόβλημα δεν φτάνει στο μενού!
Υπάρχει interface που συνδέεις και αναφέρει το προβληματικό τσιπ, αλλά δεν το έχω....
http://zxjim.blogspot.gr/

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: ZX Spectrum +2 πρόβλημα (λύθηκε!)

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Παρ Σεπ 03, 2010 12:56 am

Κοιτα το αρχικο ποστ! θα προσθεσω και αλλα αυριο πρωτα ο Θεος!!
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
ZX_Jim +
Z80 power CPU
Z80 power CPU
Δημοσιεύσεις: 1407
Εγγραφή: Παρ Σεπ 04, 2009 1:06 am
Επικοινωνία:

Re: ZX Spectrum +2 πρόβλημα (λύθηκε!)

Μη αναγνωσμένη δημοσίευσηαπό ZX_Jim + » Παρ Σεπ 03, 2010 10:59 am

Η διαφορά στην ταχύτητα του Boot είναι απλά πλασματική και λόγω διαφορετικής μνήμης, ο επεξεργαστής έχει την ταχύτητα που παίρνει από τους κρυστάλλους.

Οι συμβατές μνήμες είναι: (Με ταχύτητες 150ns ή 120ns)
Ολες οι 4164
MSM3764
TMS4164
MK4564
HM4864
MB8264
MT4264
LH2164

(Ολες αυτές είναι για ΖΧ128Κ, ZX128K+2/+3, Amstrad 464, Amstrad 6128, Commodore 64)

Στο eBay δεν έχουν 8 ευρώ η μία, έχουν περίπου 8 ευρώ οι τέσσερις με τα μεταφορικά. Οι μνήμες που έβαλες κατά την γνώμη μου δεν θα δουλεύουν σωστά, απλά περνάνε το τέστ που κάνει ο ΖΧ στην εκκίνηση. (την ώρα που κάνει τα πολύχρωμα κουτάκια στην αρχή, είναι το τεστ....).
Δοκίμασε να βάλεις στην την κάτω σειρά τις διαφορετικές μνήμες για να δεις....

Σύγκρινε τα datasheet για να δεις! ;)
http://zxjim.blogspot.gr/

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: ZX Spectrum +2 πρόβλημα (λύθηκε!)

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Παρ Σεπ 03, 2010 12:13 pm

Δουλεύουν μια χαρά! εκτός το πολύωρο τεστ ανοιχτός.. χτες έτρεξα το παιχνίδι "REVENSI" απο κασσετα κανονικά! (αχ.. θυμηθηκα τα παλια!!!)
θα γινουν και αλλες δοκιμες με μεγαλυτερα παιχνιδια.. επισης παράγγειλα νεα IC regulators 78T05 5V με 3A,αντι 2Α που εχει το κανονικο!
Απο τι κατάλαβα το regulator ειναι και ο κυριος υπεύθυνος που "καιει" τις μνημες! αν χαλασει.. οποτε με +1Α θα υπαρχει μεγαλύτερη ασφαλεια..
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
ZX_Jim +
Z80 power CPU
Z80 power CPU
Δημοσιεύσεις: 1407
Εγγραφή: Παρ Σεπ 04, 2009 1:06 am
Επικοινωνία:

Re: ZX Spectrum +2 πρόβλημα (λύθηκε!)

Μη αναγνωσμένη δημοσίευσηαπό ZX_Jim + » Παρ Σεπ 03, 2010 12:22 pm

Δεν καίει τις μνήμες το regulator,
αν βγει κάποιο interface όταν είναι αναμμένο το μηχάνημα καίγονται regulator και πολλές φορές και κάποιες μνήμες.... ;)
Αν δεν "παίζεις" με τα interface, ο ΖΧ είναι αθάνατος! ::3

Στον +2 τοποθετούσαν συχνά joystick interface, για να έχουν συμβατότητα στα PIN με τα κλασικά atari joystick....
http://zxjim.blogspot.gr/

Άβαταρ μέλους
ZX_Jim +
Z80 power CPU
Z80 power CPU
Δημοσιεύσεις: 1407
Εγγραφή: Παρ Σεπ 04, 2009 1:06 am
Επικοινωνία:

Re: ZX Spectrum +2 πρόβλημα (λύθηκε!)

Μη αναγνωσμένη δημοσίευσηαπό ZX_Jim + » Παρ Σεπ 03, 2010 1:10 pm

Γίνεται, αλλά αν μου φέρεις τα 9ΠΙΝα που χρειάζονται (αρσενικό-θηλυκό από PC), σου φτιάχνω αντάπτορα.... ;)
Μην το χαλάσεις καινούργιο μηχάνημα! :lol:
http://zxjim.blogspot.gr/

Άβαταρ μέλους
ZX_Jim +
Z80 power CPU
Z80 power CPU
Δημοσιεύσεις: 1407
Εγγραφή: Παρ Σεπ 04, 2009 1:06 am
Επικοινωνία:

Re: ZX Spectrum +2 πρόβλημα (λύθηκε!)

Μη αναγνωσμένη δημοσίευσηαπό ZX_Jim + » Παρ Σεπ 03, 2010 3:24 pm

Λοιπόν,
οι 41256 που έχεις, είναι 8μπιτες και συμβατές όσον αφορά τα ΡΙΝ, έχουν όμως διαφορές στις προδιαγραφές.....
Είναι 260ns, άρα θα ζεσταίνονται και θα βγαίνουν εκτός λειτουργίας, μέχρι να καούν κάποια στιγμή.... :(
Θέλει 150ns ή λιγότερο χρόνο προσπέλασης!
http://zxjim.blogspot.gr/

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4746
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: ZX Spectrum +2 πρόβλημα (λύθηκε!)

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Παρ Σεπ 03, 2010 4:31 pm

Είναι οι 41256P-15 που σημαίνει οτι είναι 150ns ! και δεν ζεσταίνονται! το τσέκαρα!
Βασικά ειδα μετά την αντικατάσταση οτι δεν ζεσταινόταν καθόλου οι μνήμες! (ενω πριν.. ζεσταινόταν μόνο η πάνω σειρά!)
οτι ειναι 256Κ ειναι το περίεργο πως δουλεύουν! ίσως να τις προσπερνά σαν 64Κ εξού και ο λόγος που μόνο με αυτό το συνδυασμό - εναλλάξ παίζουν σωστά!
Στην κατω σειρά.. δε παίζουν σωστά,με κανένα αλλον συνδυασμό εκτός από αυτό που ανέφερα στο κεντρικό θέμα!
Τα μόνα,που ζεσταινόταν λίγο (εξ αρχής).. ηταν ο CPU Z80 και το chip "Amstrad 40054" και μπήκαν ψήκτρες! ;)
Η βαθιά κατάσταση που επιπλέει


Επιστροφή σε “ZX Spectrum / ZX-81 / QL”



Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: 1 και 0 επισκέπτες