R tape loading error

Άβαταρ μέλους
Arielis
Μέλος
Μέλος
Δημοσιεύσεις: 15
Εγγραφή: Τρί Μαρ 27, 2012 1:56 pm

R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό Arielis » Δευ Απρ 16, 2012 9:10 pm

Καλησπέρα παιδιά!

Μετά την επιτυχημένη αλλαγή μεμβράνης, θέλησα να φορτώσω κάποια παιχνίδια στον 48άρη.
Kατεβάζω κάποια tzx από το worldofspectrum και ξεκινάω.
Παρόλο που έβλεπα ότι το εκάστοτε πρόγραμμα φορτώνονταν (μπλέ-κίτρινες και γαλάζιες-κόκκινες μπάρες ή έβλεπα το loading screen του προγράμματος), σε κάποια στιγμή μου πετούσε το καταραμένο στους Σπεκτρουμάδες, "R Tape Loading Error". :evil:
Όσο και να προσπάθησα με διαφορετικά tzx ή διαφορετικές ρυθμίσεις στον mixer του υπολογιστή (τα φόρτωνα κατεθείαν από εκεί) πότε δεν μπόρεσα να φορτώσω επιτυχώς κάποιο πρόγραμμα! :mpr

Επίσης, παρατήρησα πως μερικές φορές μόλις μπεί σε loading mode (LOAD "") η μπλέ και η κόκκινη οθόνη δεν έχουν σταθερό ρυθμό εναλλαγής μεταξύ τους.

Έχει κάποιος κάποια ιδέα τι μπορεί να συμβαίνει;

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4745
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Δευ Απρ 16, 2012 9:49 pm

Δοκίμασε αυτό εδώ και πες μας..
(Είναι σε turbo μορφή)
Μετα θα δούμε αν φταίει το καλώδιο,η ένταση, η κατι άλλο..
Δεν έχετε τα απαραίτητα δικαιώματα για να δείτε τα συνημμένα αρχεία σε αυτήν τη δημοσίευση.
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
ZX_Jim +
Z80 power CPU
Z80 power CPU
Δημοσιεύσεις: 1407
Εγγραφή: Παρ Σεπ 04, 2009 1:06 am
Επικοινωνία:

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό ZX_Jim + » Δευ Απρ 16, 2012 10:59 pm

Για έλεγξε μετά και την μνήμη σου με το παρακάτω:
viewtopic.php?f=29&t=291
http://zxjim.blogspot.gr/

Άβαταρ μέλους
Arielis
Μέλος
Μέλος
Δημοσιεύσεις: 15
Εγγραφή: Τρί Μαρ 27, 2012 1:56 pm

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό Arielis » Τρί Απρ 17, 2012 1:02 am

To PEEK με την RAM το είχα δοκιμάσει, Δημήτρη και είχε βγεί 65535 :!!
Θα δοκιμάσω το προγραμματάκι που πόσταρε ο Anemos και θα σας ενημερώσω! :thanks

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4745
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Τρί Απρ 17, 2012 1:14 am

Arielis έγραψε:Θα δοκιμάσω το προγραμματάκι που πόσταρε ο Anemos και θα σας ενημερώσω! :thanks

Game είναι, mp3 συμπιεσμένο,φορτώνεις από το PC ,η mp3 player.. ;)
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
Arielis
Μέλος
Μέλος
Δημοσιεύσεις: 15
Εγγραφή: Τρί Μαρ 27, 2012 1:56 pm

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό Arielis » Τρί Απρ 17, 2012 2:32 pm

Δοκίμασα πρίν λίγο το mp3 και το αποτέλεσμα είναι αυτό

Εικόνα

::3 ::3 ::3

Φυσικά κανένα πλήκτρο δεν λειτουργούσε. Σε άλλη προσπάθεια φορτώματος, ο Speccy μου έκανε reset! e-shock

Μέχρι τώρα φόρτωνα τα tzx αρχεία (μιας και στο linux δεν έχω βρεί κάποιο native πρόγραμμα για tap).
Προσπάθησα να φορτώσω ένα tap με το tape2wav (μέσω wine) και είδα πως τουλάχιστον στο φόρτωμα δεν μου πετάει το R Tape Loading Error.
Παρατήρησα κατά την διάρκεια του φορτώματος μετά τα data blocks (κίτρινες-μπλέ γραμμές), ο Spectrum δεν αναγνώριζε το pulse (γαλάζιες-κόκκινες γραμμές) που επακολουθούσε.
Ξαναπαίζοντας το pulse (γυρνώντας δηλαδή το wav λίγο πιο πίσω), ο Spectrum ξυπνούσε και το αναγνώριζε και άρα συνέχιζε το φόρτωμα.
Με αυτό τον τρόπο κατάφερα επιτέλους να φορτώσω το tap του Horizons! s-wow

Δοκίμασα και το zxdiag του Δημήτρη, το οποίο και εκεί μου έβγαλε ένα R Tape Loading Error στο τέλος του tap! Με ένα GO TO 0 όμως έπαιξε, βγάζοντας το "RAM is OK"
(υποθέτω πως το πρόγραμμα απλά έχει μαζεμένα όλα τα PEEKs από εδώ για ευκολότερο checking! BTW πολύ καλή δουλειά Δημήτρη)

Καμιά ιδέα;

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4745
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Τρί Απρ 17, 2012 2:54 pm

Με τι καλώδιο και βύσματα δοκιμάζεις?
Από PC σε ZX θέλει από stereo σε μονοφωνικό για το EAR.. viewtopic.php?f=24&t=46
Κάτι τρέχει με την καθαρότητα (παράσιτα) η την ένταση του ήχου..
Δοκίμασε να καθαρίσεις την υποδοχή του EAR, στρίβοντας - μακαρόνι μια χαρτοπετσέτα στο μέγεθος της υποδοχής EAR ,βρέξε την με λίγο οινόπνευμα, και "στριφογύρισε" την στη υποδοχή..
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
Arielis
Μέλος
Μέλος
Δημοσιεύσεις: 15
Εγγραφή: Τρί Μαρ 27, 2012 1:56 pm

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό Arielis » Τρί Απρ 17, 2012 2:57 pm

Το καλώδιο είναι αυτό που είχε ο Spectrum μαζί του, το μονοφωνικό.
Θα καθαρίσω και τα βύσματα και τις υποδοχές!
Ευχαριστώ!

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4745
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Τρί Απρ 17, 2012 2:59 pm

Οχι δεν κάνει.. θες να φτιάξεις αυτό> viewtopic.php?f=24&t=46
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
ZX_Jim +
Z80 power CPU
Z80 power CPU
Δημοσιεύσεις: 1407
Εγγραφή: Παρ Σεπ 04, 2009 1:06 am
Επικοινωνία:

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό ZX_Jim + » Τρί Απρ 17, 2012 4:25 pm

Πρέπει να είναι το βύσμα σου! Συνδέεις stereo πηγή, με μονοφωνικό καλώδιο!
"Χάνεις" το ένα κανάλι και δημιουργεί "βόμβο"!
Φτιάξε αυτό που προτείνει ο Anemos! :!!

Arielis έγραψε:...(υποθέτω πως το πρόγραμμα απλά έχει μαζεμένα όλα τα PEEKs από εδώ για ευκολότερο checking! BTW πολύ καλή δουλειά Δημήτρη)...

Ναι, σωστά μάντεψες ;)
Ευχαριστώ!
http://zxjim.blogspot.gr/

Άβαταρ μέλους
nikosdoykas
Μέλος
Μέλος
Δημοσιεύσεις: 91
Εγγραφή: Πέμ Μαρ 17, 2011 10:08 am

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό nikosdoykas » Δευ Απρ 23, 2012 7:44 pm

προτον στερεο σε μονοφωνικο ειναι μονοδρομος yes-yes
δευτερον παρατιρισα οτι μερικα παιχνιδια δεν φωρτωνουν (κακο τζχ) :provlimatismenos ::7 ::3
τριτον αλλα ασυμπιεστα στο k7zx μου τρεχουν...... :provlimatismenos
τεταρτον με τζχ το wav παρατιρισα οτι ηκυματομορφη ειναι τετραγωνη και τιποτα δεν φωρτωνε
στο k7zx βγαινει ημιτονοειδης και φωρτωνουνν... ::6

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4745
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Δευ Απρ 23, 2012 7:50 pm

5ον, παίρνεις ενα DIVIDE και ξενοιάζεις μια για πάντα.. :lol:
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
nikosdoykas
Μέλος
Μέλος
Δημοσιεύσεις: 91
Εγγραφή: Πέμ Μαρ 17, 2011 10:08 am

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό nikosdoykas » Δευ Απρ 23, 2012 10:31 pm

εχω αλλα δεν το γουσταρωωωω
μπορει να το δωσω κιολας....

Άβαταρ μέλους
Anemos
AMD 4 ever?
AMD 4 ever?
Δημοσιεύσεις: 4745
Εγγραφή: Τρί Σεπ 01, 2009 12:40 am

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό Anemos » Δευ Απρ 23, 2012 10:55 pm

Να φορτώνεις 1-2 φορές απο κασέτα η απο mp3, για να θυμηθείς τα παλιά οκ, αλλά το να περιμένεις 10 λεπτά καθε παιχνίδι δε λεει.. huh-man
Τώρα για τo K7ZX έχω να πω ότι δεν είναι και 100% συμβατά αυτά που βγάζει,θα έλεγα ενα 50% το πολύ,με πολλές δοκιμές στην διαμόρφωση ήχου (ανάλογα και το game)..
Οσο αφορά τα χαλασμένα TZX,TAP κτλ.. μπορεις να τεσταρεις πρωτα σε εναν emulator για ΖΧ, π.χ τον Spin.
Η βαθιά κατάσταση που επιπλέει

Άβαταρ μέλους
Arielis
Μέλος
Μέλος
Δημοσιεύσεις: 15
Εγγραφή: Τρί Μαρ 27, 2012 1:56 pm

Re: R tape loading error

Μη αναγνωσμένη δημοσίευσηαπό Arielis » Πέμ Μάιος 10, 2012 7:21 pm

Αμέλησα να απαντήσω εδώ!

Έφτιαξα το καλωδιάκι Stereo 2 Mono, αλλά και πάλι τα ίδια...
Τα tzx κόλλαγαν ενώ το z80 αρχείο του Άνεμου, είχε το ίδιο αποτέλεσμα. :(

Του έκανα recapping (προληπτικά), και πάλι τα ίδια.
Μάλλον θα το παρατήσω προς το παρόν... Τουλάχιστον έγινε ένα καλό φρεσκάρισμα του μηχανήματος σε περίπτωση που μου ξανάρθει η όρεξη.


Επιστροφή σε “ZX Spectrum / ZX-81 / QL”



Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: 1 και 0 επισκέπτες